Bounty event is telling me to update

So, I’m a 100mil into the bounty event when the game tells me I need to get the newest version to be able to participate in the event. Thing is, I have the newest version already. What gives?

I’m no dev or anything but the general consensus is that the bountys you had live when you updated are the ones that are asking you to update in order to hit them but you should still be able to hit newer bounties that you summon. You just have to miss out on the points for those bounties that require you to “update” it isn’t a fix just wait until the escape.

Gl in bounty.

It isn’t that, because I updated before the bounty event fame out, and I still couldn’t play a few bounties.

Defentily a problem cause ive had the update before bounties and i cant play half the summond bounties myself… im running on android as well